Home » Developer & Programmer » Forms » Arabic characters are displaying as question marks in forms 12c (Oracle forms 12c , Oracle Linux 7.9)
Arabic characters are displaying as question marks in forms 12c [message #685663] Tue, 01 March 2022 11:23 Go to next message
RAY_HT
Messages: 155
Registered: May 2005
Location: Giza
Senior Member
We have migrated our application from forms 10g running on windows OS to forms 12c running on Oracle Linux 7.9 after WebLogic and forms domain created and configured successfully.
now the Arabic characters are displayed as question marks or symbols while it displays correctly in the old application using forms 10g on windows.

we set the NLS_LANG to ARABIC_EGYPT.AR8MSWIN1256 but it doesn't work.

is there any documentation for how to configure it in Linux ?
Re: Arabic characters are displaying as question marks in forms 12c [message #685664 is a reply to message #685663] Tue, 01 March 2022 11:55 Go to previous messageGo to next message
Michel Cadot
Messages: 68258
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

My guess is that your previous application/environment was badly configure and has inserted wrong data.
See this topic.

[Updated on: Tue, 01 March 2022 11:56]

Report message to a moderator

Re: Arabic characters are displaying as question marks in forms 12c [message #685671 is a reply to message #685664] Wed, 02 March 2022 07:28 Go to previous message
RAY_HT
Messages: 155
Registered: May 2005
Location: Giza
Senior Member
Thank you Michel for your response.

may I didn't clarify the issue, the issue is not in DATA, it is in the form field Titles and menu items it doesn't display Arabic characters correctly
Previous Topic: Big dmp files on Weblogic Server 12.2.1.4
Next Topic: Capturing video web cam using API
Goto Forum:
  


Current Time: Sun Aug 14 04:48:09 CDT 2022