Home » Developer & Programmer » Forms » ON-LOGON trigger not working (merged) (Oracle Forms 6i)
ON-LOGON trigger not working (merged) [message #689386] Mon, 04 December 2023 05:53 Go to next message
mfahimaamirgmailcom
Messages: 62
Registered: May 2011
Location: pakistan
Member
Dear friend
we user below code in  ON-LOGON trigger but that no working

DECLARE
UN VARCHAR2(80) := 'hr';
PW VARCHAR2(80) := 'hr';
 --     DB  VARCHAR2(80) := 'xe' --ORCL being your database identifier.


--LOGON(UN, PW||'@'||DB); ---  this line give me error
LOGON(UN, PW);     ---is ok


but this code not working

please give me idea also see the image which oracle form version  
is too good and easy i can give UID ,PWD and database name easily

regard
Re: ON-LOGON trigger not working (merged) [message #689389 is a reply to message #689386] Tue, 05 December 2023 04:07 Go to previous message
Littlefoot
Messages: 21811
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Forms 6i's LOGON procedure accepts 2 (plus additional optional) parameters:

- username: any valid username of up to 80 characters
- password: any valid password of up to 80 characters, including a database connect string

which means that you used it properly. Documentation example shows

DECLARE
   un  VARCHAR2 (80);
   pw  VARCHAR2 (80);
   cn  VARCHAR2 (80);
BEGIN
   get_connect_info (un, pw, cn);

   IF cn IS NOT NULL
   THEN
      LOGON (un, pw || '@' || cn);
   ELSE
      LOGON (un, pw);
   END IF;
END;
which suggests that you did it OK.

The question is: which error did you get? Saying that "this code isn't working" doesn't help much. What happened?
Previous Topic: forms-40010 cannot read form Z:\ORAFMX\GENLOGIN.fmx
Next Topic: disable previous record;
Goto Forum:
  


Current Time: Sun May 26 09:56:09 CDT 2024